4D-jp 4D Japan Technical Support Team

TLSのバージョン

2021-08-26

v17以降,ネットワークレイヤーのセキュリティが強化され,TLSの最低バージョンがTLS_1.2に引き上がられました。TLS_1.2に対応していないサーバーに対してHTTP Requestを使用した場合,エラー30が返されます。これは仕様です。必要に応じ,SET DATABASE PARAMETERでTLSのバージョンを変更してください。

v18以降,4Dが使用しているOpenSSLのバージョンは1.1.1にアップデートされました。必要に応じ,TLSのバージョンを1.3に設定することもできます。v18にはTLSv1_3という定数がないため,値の4を渡してください。


関連記事

リンク