4D-jp 4D Japan Technical Support Team

SMTPサーバーのTLSバージョン


Internet Commandsではメールが送信でき,SMTP Transporterでは送信できない場合,SMTPサーバーのTLSバージョンが古い可能性があります。これは仕様です。サーバーがTLS_1.1またはTLS_1.2をサポートしていない場合,checkConnectivity()でエラー 42 43 49が返されます。これに対応するOpenSSL内部エラーメッセージは下記のとおりです。

1425F102:SSL routines:ssl_choose_client_version:unsupported protocol

古いSMTPサーバーを使用する場合,4DのデフォルトTLSバージョンを引き下げる必要があります。

SET DATABASE PARAMETER(Min TLS version;TLSv1_0)

関連記事

リンク